Configuring the OCI HA interfaces | OCI Administration Guide (2024)

OCI recommends leaving VM NIC interfaces set to DHCP. This is to avoid potential misaligned configurations. However, when configuring an NVA, you may need to ignore this recommendation. When doing so, ensure that the IP addresses correspond with those intended, so that to the extent required, the configurations match.

In the case of HA, the FortiGate-VMs must have the correct IP address information statically configured to provide proper failover between the two devices.

Configuring the OCI HA interfaces | OCI Administration Guide (1)

OCI API calls enable the failover mentioned above through the OCI Fabric connector, but only for IP addresses configured as secondary in the OCI VNIC configuration.

Also, OCI API calls, if initiated from within a VCN, must be made by a primary interface with a public address with DNS properly configured. Thus, the network configuration for OCI HA is unique and specific.

Configuring the OCI HA interfaces | OCI Administration Guide (2)

You may lose connection to the instance during interface IP address and route configuration. Therefore, performing this configuration via the console is recommended.

Primary FortiGate

port1

The primary VNIC associated with the FortiGate NVA must have a primary IP address with a corresponding public IP address, and so needs to be configured in a public subnet. This is used as a management interface and also the interface from which API calls are made. You assign this in the HA configuration). See this interface's OCI configuration, then the corresponding FortiGate-VM configuration.

Configuring the OCI HA interfaces | OCI Administration Guide (3)

config system interface

edit "port1"

set vdom "root"

set ip 10.0.0.3 255.255.255.0

set allowaccess ping https ssh http fgfm

set description "management"

set mtu-override enable

set mtu 9000

next

end

port2

Beyond port1 (also the primary VNIC), interface order is arbitrary and you can rearrange it. This example assumes port2 to be a public/WAN-facing interface. The following FortiGate configuration does not use the primary IP address for its interface IP address. Instead, the configuration uses the non-primary private IP address, as shown. This is because the primary IP address is not relocatable to the secondary FortiGate in the event of HA failover. In this example, the FortiGate uses a single secondary IP address with an associated public IP address. In the case of a failover, the secondary IP address and associated public IP address are migrated from the active to the passive FortiGate. Therefore, if the setup uses any extra non-primary private IP addresses in the setup, you must explicitly reference these IP addresses in the interface configuration by enabling secondary IP addresses.

Configuring the OCI HA interfaces | OCI Administration Guide (4)

config system interface

edit "port2"

set vdom "root"

set ip 10.0.12.3 255.255.255.0

set allowaccess ping https ssh fgfm

set description "untrust"

set secondary-IP enable

set mtu-override enable

set mtu 9000

config secondaryip

edit 1

set ip 10.0.12.5 255.255.255.0

set allowaccess ping https ssh fgfm

next

end

next

end

port3

This example configures port3 as the internal port, which the configuration uses to connect to internal resources on local subnets, peered VCNs, and so on. However, as aforementioned, FortiGate does not use the primary IP address. You must still attach the VNIC to the instance with the primary IP address. However, the configuration is synced from the primary FortiGate.

Configuring the OCI HA interfaces | OCI Administration Guide (5)

config system interface

edit "port3"

set vdom "root"

set ip 10.0.8.10 255.255.255.0

set allowaccess ping https ssh fgfm

set description "trusted"

set mtu-override enable

set mtu 9000

next

end

Enabling Skip Source/Destination Check for the VNIC is recommended.

port4

This example uses port4 as the HA interface for heartbeat and configuration synchronization. As such, it only needs a single private IP address.

Configuring the OCI HA interfaces | OCI Administration Guide (6)

config system interface

edit "port4"

set vdom "root"

set ip 10.0.10.3 255.255.255.0

set allowaccess ping https ssh fgfm

set description "heartbeat"

set mtu-override enable

set mtu 9000

next

end

Additional configuration

For any unconnected subnets or networks, the FortiGate needs a route assigned to know how to get to them. Typically, you connect these via the internal designated interface. In this case, this is port3. Therefore, a route with a next hop or gateway of the first IP address of the subnet to which port3 belongs is necessary. This can be a specific host route or summary route of some sort.

See the following, where a summary route is configured for 10.0.0.0/16. If this route is not added, the FortiGate communicates with any unconnected routes through the default (0.0.0.0/0) route, which typically should be out the WAN interface (port2 in this example). Since all interfaces are being configured statically and you are not configuring a default route through DHCP, you must also add this default route. If you do not set a destination, FortiOS assumes the default route of 0.0.0.0/0. Therefore, the 2 configuration is the default route.

config router static

edit 2

set gateway 10.0.12.1

set device "port2"

next

edit 3

set dst 10.0.0.0 255.0.0.0

set gateway 10.0.8.1

set device "port3"

next

end

Secondary FortiGate

For the secondary FortiGate, you do not need to configure port2 or port3, as these configurations should sync from the primary FortiGate.

port1

The primary VNIC associated with the FortiGate NVA must have a primary IP address with a corresponding public IP address, and so must be configured in a public subnet. This is used as a management interface and also the interface from which API calls are made. You assign this in the HA configuration). See this interface's OCI configuration, then the corresponding FortiGate-VM configuration.

Configuring the OCI HA interfaces | OCI Administration Guide (7)

config system interface

edit "port1"

set vdom "root"

set ip 10.0.0.4 255.255.255.0

set allowaccess ping https ssh http fgfm

set description "management"

set mtu-override enable

set mtu 9000

next

end

port2

You must attach the VNIC to the instance with the primary IP address. However, the FortiGate syncs the configuration from the primary unit.

Configuring the OCI HA interfaces | OCI Administration Guide (8)

port3

You must attach the VNIC to the instance with the primary IP address. However, the FortiGate syncs the configuration from the primary unit.

Configuring the OCI HA interfaces | OCI Administration Guide (9)

port4

This example uses port4 as the HA interface for heartbeat and configuration synchronization. As such, it only needs a single private IP address.

Configuring the OCI HA interfaces | OCI Administration Guide (10)

config system interface

edit "port4"

set vdom "root"

set ip 10.0.10.4 255.255.255.0

set allowaccess ping https ssh fgfm

set description "heartbeat"

next

end

Configuring the OCI HA interfaces | OCI Administration Guide (2024)

FAQs

How will you configure high availability for an application in an OCI region? ›

Q2: How will you configure high availability for an application in an oracle cloud infrastructure region with a single availability domain? Ans: Setup your application across multiple Fault Domains and the database tier contains Oracle Cloud Infrastructure Database instances.

How do you configure management interface reservation? ›

Configuration using GUI:

Go to System -> HA, edit the Chassis with the Primary role, and enable Management Interface Reservation. The 'Interface' field will be the interface used for management access. This can be mgmt1, mgmt2, or mgmt3. Now, configure the port intended for HA management.

How can we configure high availability in oracle? ›

  1. Step 1: Creating Server Wallet and Certificate.
  2. Step 2: Creating Client (Agent) Wallet and Certificate.
  3. Step 3: Exchanging Client (Agent) and Server Certificates.
  4. Step 4: Configuring Server Network.
  5. Step 5: Connecting to DBCS instances in TCPS mode.

How to configure high availability server? ›

To set up servers in a high-availability configuration, you install the server on separate systems and connect the servers to the same database. Then, you configure a load balancer to distribute the traffic between the servers. Instead of accessing the servers directly, users access the load balancer URL.

How do you configure an existing VM for high availability? ›

You can import your vm to either host in the cluster using Hyper-V manager. Once its imported go into Failover Cluster Manager and choose Configure Role > Virtual Machine and your newly imported vm should show up to configure for high availability.

How do you configure disk quotas? ›

Setting up disk quotas

This is because disk quotas may be initially disabled for users that already have files on the drive. To access disk quota options, we want to first go to File Explorer. Once in File Explorer, we'll want to right-click on the drive we want to set up disk quotas for and select Properties.

How to configure HA in fortigate firewall? ›

Fortigate HA Configuration
  1. Go to System ->Select HA.
  2. Select mode Active-Passive Mode.
  3. Once Active-Passive mode is selected multiple parameters are required.
  4. Mode- Active/ Passive.
  5. Set Device Priority -200. ...
  6. Device Group– The group name must be the same for both primary and secondary devices.
May 22, 2023

How will you optimize availability of your application in a cloud environment? ›

Best Practices to Optimize Your Cloud Environment
  • Right Sizing Cloud Resources. ...
  • Address Anomalies. ...
  • Making Use of Spot and Reserved Instances. ...
  • Use Automated Tools to Streamline and Automate Optimization Tasks. ...
  • Using Managed Service Providers (MSPs) for Cost Optimization. ...
  • Utilizing AI for Cost Optimization.

How do I make an application high availability? ›

How to Achieve High Availability
  1. Use Autoscaling. ...
  2. Choose Between Complexity and Simplicity. ...
  3. Implement Multiple Application Servers. ...
  4. Enable Monitoring. ...
  5. Implement Load Balancers. ...
  6. Configure Failover Setup. ...
  7. Try Clustering Techniques. ...
  8. No Single Points of Failure.
Oct 5, 2021

How can you get high availability for global applications? ›

Use of Multiple Application Servers:

The obvious solution here is to deploy your application over multiple servers. You need to distribute the load among all these, so that none of them are overburdened and the output is optimum. You can also deploy parts of your application on different servers.

How do you get high availability in cloud computing? ›

A 5-Step Azure High Availability Checklist
  1. Define Availability Requirements. Identify the cloud workloads that require high availability and their usage patterns. ...
  2. Plan your High Availability Architecture. ...
  3. Perform End-to-End Testing. ...
  4. Deploy Applications Consistently. ...
  5. Monitor Application Health.

References

Top Articles
66 Games Unblocked | Games 66 EZ
Cute Monkey Mart . Online Games . BrightestGames.com
Zuercher Portal Inmates Clinton Iowa
Morgandavis_24
15:30 Est
Atrium Attorney Portal
Caremount Medical Flu Shots 2022
Wharton County Busted Newspaper
Press And Sun-Bulletin Obits Today
Pa Pdmp Log In
Lebron Vs Pacers Stats
Momokun Leaked Controversy - Champion Magazine - Online Magazine
Zulrah Strat Osrs
Dallascowgirl Leaked Of
Slmd Skincare Appointment
Please Put On Your Jacket In Italian Duolingo
Walking through the Fire: Why nothing stops Jesus’ love for you - Ann Voskamp
Test Nvidia GeForce GTX 1660 Ti, la carte graphique parfaite pour le jeu en 1080p
9:00 A.m. Cdt
Ninaisboring
O'reilly Auto Parts Near Me Open Now
Ticket To Paradise Showtimes Near Movie Tavern Bedford
Craigslist Truck
Skip The Games Lawton Oklahoma
Minneapolis, MN Real Estate & Homes for Sale | realtor.com®
2010 Ford F-350 Super Duty XLT for sale - Wadena, MN - craigslist
Dr. Nicole Arcy Dvm Married To Husband
Restaurants Near Defy Trampoline Park
Nyu Paralegal Program
Reasonabiu
Southern Food Buffet Near Me
321 Flea Market Gastonia Nc
Age Gabriela Moura's Evolution from Childhood Dreams to TikTok Fame - Essential Tribune
Rubios Listens Com
No Cable Schedule
Acnh Picnic Table
100000 Divided By 3
Heiwa Coin
How Did Laura Get Narally Pregnant
Jbz Inlog
Oprichter Haagse rapgroep SFB doodgeschoten, wie was hij?
The Little Mermaid 2023 Showtimes Near Marcus South Pointe Cinema
Where does the Flying Pig come from? - EDC :: Engineering Design Center
Curaleaf Announces Majority Stake and Forms Strategic Partnership with Germany's Four 20 Pharma, a Fully EU-GMP & GDP Licensed Producer and Distributor of Medical Cannabis
Az610 Flight Status
The Spot Barbershop - Coconut Creek Reviews
Riscap Attorney Registration
American Idol Winners Wiki
Kieaira.boo
Vidant My Chart Login
8 Internet Celebrities who fell prey to Leaked Video Scandals
Trivago Anaheim California
Latest Posts
Article information

Author: Lilliana Bartoletti

Last Updated:

Views: 6185

Rating: 4.2 / 5 (73 voted)

Reviews: 80% of readers found this page helpful

Author information

Name: Lilliana Bartoletti

Birthday: 1999-11-18

Address: 58866 Tricia Spurs, North Melvinberg, HI 91346-3774

Phone: +50616620367928

Job: Real-Estate Liaison

Hobby: Graffiti, Astronomy, Handball, Magic, Origami, Fashion, Foreign language learning

Introduction: My name is Lilliana Bartoletti, I am a adventurous, pleasant, shiny, beautiful, handsome, zealous, tasty person who loves writing and wants to share my knowledge and understanding with you.